Skip to main content
Topic: UNEXPECTED ERROR SplitCam 10.7.7 x64 (Read 2860 times) previous topic - next topic

UNEXPECTED ERROR SplitCam 10.7.7 x64

After saving the config file, and reopen SplitCam, I get following error:


UNEXPECTED ERROR: See log output for more info. Code: 0xC0000005, Flags: 0. Address 0x00007FF62872441B

If I delete default.xml, the app starts succesfully, but after saving new config-file, the same error happens again.

This is in the logfile

====================================================

09:18:52 SplitCam starting: v10.7.7 x64
09:18:52 CPUID: Intel64 Family 6 Model 154 Stepping 3, GenuineIntel
09:18:52 Processor: 12th Gen Intel(R) Core(TM) i7-1260P
09:18:52 OS: Microsoft Windows 11 Pro 10.0.22621 64 bits
09:18:52 Initializing Gdiplus
09:18:52 Gdiplus initialized
09:18:52 Creating app object
09:18:52 Resetting project to defaults
09:18:52 Deleting scenes
09:18:52 Done deleting scenes
09:18:52 Clearing stream settings
09:18:52 Deleting streams
09:18:52 Done deleting streams
09:18:52 Creating deafult scene
09:18:52 Failed to open default wave output device
09:18:52 Initializing scene object
09:18:52 Creating video capture sources
09:18:52 Creating video capture renderers
09:18:52 Creating video capture canvas
09:18:52 Creating chat notifier
09:18:52 Creating chat notifier layer
09:18:52 Saving created context to static contexts list
09:18:52 Setting video callback
09:18:52 Setting default canvas size to 1280x720
09:18:52 Setting canvas callback
09:18:52 Setting audio callback
09:18:52 Registering deafult scene
09:18:52 Getting default project path
09:18:52   C:\Users\jware\AppData\Local\Splitcam\default.scproject
09:18:52 Initializing default theme
09:18:52 Startup project file doesn't exist: ""
09:18:52 Running app
09:18:52 Displaying splash screen
09:18:52 Cleaning program cache files
09:18:52 Loading options from "C:\Users\jware\AppData\Local\Splitcam\options.xml"
09:18:52 Loading local copies of ingest and restream servers lists
09:18:52 Updating the list of restream servers
09:18:52 Done updating the list of restream servers
09:18:53 Initializing common controls
09:18:53 Common controls inited
09:18:53 Initializing resources
09:18:53 Saving "loading.gif" resource to file
09:18:53 Resources initialized
09:18:53 Initializing cloud config
09:18:53 Finished initialization of cloud config
09:18:53 Setting up workspace
09:18:53 Loading last project: "C:\Users\jware\AppData\Local\Splitcam\default.xml"
09:18:53 Checking available GPUs
09:18:54 1 GPU found in the system.
09:18:54   Intel GPU: Intel(R) Iris(R) Xe Graphics
09:18:54 Loading project file "C:\Users\jware\AppData\Local\Splitcam\default.xml"
09:18:54 Deleting scenes
09:18:54 Deleting video context
09:18:54 Stopping capture sources
09:18:54 Looking for current context in static context list
09:18:54 Deleting notifier
09:18:54 Deleting capture sources
09:18:54 Deleting renderers
09:18:54 Deleting canvas
09:18:54 Canvas thread stopped
09:18:54 Done deleting scenes
09:18:54 Deleting streams
09:18:54 Done deleting streams
09:18:54 Failed to open default wave output device
09:18:54 Initializing scene object
09:18:54 Creating video capture sources
09:18:54 Creating video capture renderers
09:18:54 Creating video capture canvas
09:18:54 Creating chat notifier
09:18:54 Creating chat notifier layer
09:18:54 Saving created context to static contexts list
09:18:54 Setting video callback
09:18:54 Setting default canvas size to 1280x720
09:18:54 Setting canvas callback
09:18:54 Setting audio callback
09:18:54 Updating scenes
09:18:54 Creating memory renderer for splitcam driver.
09:18:54 Error creating decoder from file "C:\Users\jware\AppData\Local\Splitcam\loading.gif" in ImageLoader: 0x800401F0.
09:18:54 Activating scene 0
09:18:54 Finished setting up work space.
09:18:54 Starting UI
09:18:54 Destroying splash screen
09:18:54 SplitCam started
09:18:54 SYM Symbol-SearchPath: '.', symOptions: 530, UserName: 'jware'
09:18:54 Updating proxy servers
09:18:54 Downloading "https://splitcam.com/win-download/update/proxy.cfg" to "C:\Users\jware\AppData\Local\Splitcam\proxy.cfg"
09:18:55 Available desktop size: 1360x720
09:18:55 Creating dialog class ui::CStatisticsWindow, "CPU" at (641, 323) of size 640x392
09:18:55 Creating dialog class ui::CStatisticsWindow, "GPU" at (641, 323) of size 640x392
09:18:55 Creating dialog class ui::CStatisticsWindow, "RAM" at (641, 323) of size 640x392
09:18:55 Creating dialog class ui::CStreamStatistics, "Stream Statistics" at (641, 323) of size 640x392
09:18:55 Show Statistics panel.
09:18:55 Initializing virtual driver interface
09:18:55 SYM 00007FF62872441B (splitcam): (filename not available): (function-name not available)
09:18:55 SYM 00007FF628725790 (splitcam): (filename not available): (function-name not available)
09:18:55 SYM 00007FFFBE5126AD (KERNEL32): (filename not available): BaseThreadInitThunk
09:18:55 SYM 00007FFFC03CAA68 (ntdll): (filename not available): RtlUserThreadStart
09:18:55 UNEXPECTED ERROR. See log output for more info.
 Code: 0xC0000005.
 Flags: 0.
 Address: 0x00007FF62872441B.

09:18:55 Acivating scene 0
09:18:55 Memory usage:

        Total RAM : 15,988 MiB
         Free RAM : 11,493 MiB
         RAM Load : 28%
     SplitCam RAM : 254 MiB
     SplitCam CPU : 4.1%
     SplitCam GPU : 5.1%

09:18:55 Creating dialog class ui::CDlgAbout, "About SplitCam" at (380, 0) of size 600x720
09:18:55 Reading from "https://splitcam.com/win-download/update/history.txt"
09:18:57 Initializing chat notifier
09:18:57 Finished initializing chat notifier
09:18:57 Updating chat client
09:18:57 Finished updating chat client
09:19:24 Error running speed test: [json.exception.parse_error.101] parse error at line 2, column 1: syntax error while parsing value - unexpected '{'; expected end of input

====================================================

If I understand it correctly, SplitCam makes some error while creating the config-file

Host is Windows 11 Pro. Machine is Intel NUC12WSKi7.

Please help me to fix the issue

Re: UNEXPECTED ERROR SplitCam 10.7.7 x64

Reply #1
I could find the origin. I had sound disabled in Bios. After enabling everything worked fine now

Re: UNEXPECTED ERROR SplitCam 10.7.7 x64

Reply #2
Thank you for reporting about the reason of this error. I was wrestling with the search of what was the cause.
Toto,
SplitCam development and support team.

Re: UNEXPECTED ERROR SplitCam 10.7.7 x64

Reply #3
Hi, i have similar issues but the address is different. I checked my BIOS and audio is enabled so it's not the same cause. May I know where to find default,xml?