Skip to main content
Topic: Was working fine, now splitcam exception, unknown error? (Read 66 times) previous topic - next topic

Was working fine, now splitcam exception, unknown error?

Hello, I have been using splitcam at a university so we can use our IP cameras in zoom. This has worked very well since august.
However, now, for apparently no reason, I have a number of computers that started doing the following:

When split cam starts, it loads, then tries to load the default.xml which has the camera definition. It seems to start
for a split second, then crashes with the error:

Splitcam Exception
     Unknown Error occurred.

I have reinstalled splitcam. I have upgraded to the latest version. I have updated windows. Thinking it might have been a windows update, I also went back and downgraded windows by using an old clone I had. All of these produce the same result. Interestingly, I can go to machine A and try it on a different camera than the one it is using, and I get the same result.

The only way to clear this error is to delete the default.xml file.Of course, then you can not see the camera. I can configure the camera, and then it works, however, if you save that configuration and quit and start splitcam, you get the same error.

Again, I can do a fresh install of splitcam, and add an IP camera and save it. When I load splitcam, it will throw the error. If I go to my LOCALAPPDATA and remove default.xml, it will load again, with no cameras. If I save it, or any other camera we have, it will again throw the error.

I am baffled at this problem. Any help would be greatly appreciated, as we fear that all of them will start doing this and we will not be able to have our zoom meetings. Again, this just started with one computer, but it seems to be spreading to others.

Re: Was working fine, now splitcam exception, unknown error?

Reply #1
Hello

Try to start your splitcam :  with hold shift + start splticam .
It's back all your settings to default.
After try create new project with new layers.
Don't load old projects.
Let me know please if it help you or not?

Thank You

Re: Was working fine, now splitcam exception, unknown error?

Reply #2
Very interesting... when I do that, it loads splitcam, but then when I go to add the IP camera, it completely exits with no error.
What I am doing:

  • Click the plus to add camera in media layer
  • Click the IP camera entrty
  • Add my camera (rtsp://myuser:[email protected]/cam1/mpeg4)
  • Click Add
  • Splitcam immediately exits, no warning, no error
  • Trying to launch splitcam again gives original "Splitcam exception Unknown error occured" error

Just to add a note here: After I hold shift and launch splitcam, if I do not add any items to media layers, and I quit, I can reopen it without error. I noticed this on the first machine that was giving me trouble. If I add the camera, it will work as normal until I save and exit, then it will never load right again until I delete the default.xml file. The truly baffling thing is that this is now happening on two completely separate Windows 10 computers pointing to two completely separate cameras.